Quantcast

Vantage Pannel Issues

MartinLogan Owners (MLO)

Help Support MartinLogan Owners (MLO):

audiogeek1007

Member
Joined
Feb 20, 2006
Messages
10
Reaction score
0
Today I had one of my pannels start making a sizzling, popping sound. Even after the music stoped playing and i powered off the amp and unplugged the speaker it still popped for about another minute. I switched amp channels to make sure it wasnt my amp. I left them unplugged for 8 hours, vacuumed the pannel and it still sizzled. Called ML and spoke to Melody and she was great. They are sending me out a new Pannel. Anyone else have this happen. Just to let you all know my room is dust free, the speakers are less than two months old and were mfg in June. Any ideas besides replacing the pannel is greatly appreciated.

Jeff
 

amey01

Well-known member
Joined
May 22, 2005
Messages
4,997
Reaction score
19
Location
Queensland, Australia
audiogeek1007 said:
Today I had one of my pannels start making a sizzling, popping sound. Even after the music stoped playing and i powered off the amp and unplugged the speaker it still popped for about another minute. I switched amp channels to make sure it wasnt my amp. I left them unplugged for 8 hours, vacuumed the pannel and it still sizzled. Called ML and spoke to Melody and she was great. They are sending me out a new Pannel. Anyone else have this happen. Just to let you all know my room is dust free, the speakers are less than two months old and were mfg in June. Any ideas besides replacing the pannel is greatly appreciated.

Jeff
It really sounds like there is some sort of debris in your panel.......dust or some other foreign object, however vacuuming should have removed this. All electrostatics are prone to these sort of noises from time to time - depending on how bad it was.
 

audiogeek1007

Member
Joined
Feb 20, 2006
Messages
10
Reaction score
0
amey01 said:
It really sounds like there is some sort of debris in your panel.......dust or some other foreign object, however vacuuming should have removed this. All electrostatics are prone to these sort of noises from time to time - depending on how bad it was.
They have been vacuumed and i went over every inch with a flashlight and there is no dust on them. They're also so new.
 

kirkawall

Well-known member
Joined
May 20, 2006
Messages
110
Reaction score
0
audiogeek1007 said:
They have been vacuumed and i went over every inch with a flashlight and there is no dust on them. They're also so new.
Hi,

I'ved had a problem with frequency-related distortion in my new Vantages -- the right panel mostly. I'm taking them in today in order to have one of the circuit boards replaced. I'll post here with the results. You might contact ML if the problem persists. It's possible that they're aware of it and can help you out with advice and/or a replacement part.

best,


k
 

wipper snapper

Well-known member
Joined
Apr 25, 2006
Messages
47
Reaction score
0
kirkawall said:
Hi,

I'ved had a problem with frequency-related distortion in my new Vantages -- the right panel mostly.

best,

k
This is the same problem I'm having with the Summits.(Both panels)
 

jmschnur

Well-known member
Joined
Feb 10, 2006
Messages
702
Reaction score
1
Location
Northern Virginia
I wonder how many isses there are with these. So far I am ok.

I am somewhat surprised at hte panel issue-but perhpas that is a case of bad mounting.

The xover could be bad soldering or a part that went bad after a mont of use. This does happen occasionally.

How tough is the quality control on these speakers before shipment?
Joel
 

Joey_V

Well-known member
Joined
Aug 17, 2005
Messages
4,379
Reaction score
0
Location
Dallas, TX
jmschnur said:
I wonder how many isses there are with these. So far I am ok.

I am somewhat surprised at hte panel issue-but perhpas that is a case of bad mounting.

The xover could be bad soldering or a part that went bad after a mont of use. This does happen occasionally.

How tough is the quality control on these speakers before shipment?
Joel
One must understand that shipping these speakers can easily introduce panel problems as the box isnt exactly UPS or Freight proof and much of the foam does not protect the panels integrity persay moreso the foams in the packaging of the Vantage use the panel as a support to protect the upper half of the box.

I'm sure QC is fine... remember that this is a site where owners discuss problems and this provides you with a skewed sample population from which you cant reliably draw the conclusion that ML has poor QC.
 

kirkawall

Well-known member
Joined
May 20, 2006
Messages
110
Reaction score
0
wipper snapper said:
This is the same problem I'm having with the Summits.(Both panels)
Hi again,

Right -- I've taken my Vantages in for the mod. It'll be a few days but I did hear the store demos, which also had this problem, after they received the new boards mod. The problem had disappeared. Highs were pure and extended even on piano music and solo female voice and there were none of the distortions/cutting out that I've been hearing on mine. I'll update on this next week but there may yet be hope...

best,

k
 

kirkawall

Well-known member
Joined
May 20, 2006
Messages
110
Reaction score
0
Hi all,

Sorry to report that, having been serviced and updated with the power supply boards replaced, my Vantage problem has not been resolved. Still frequency-related distortionon the right panel independent of volume. My dealer will be bringing in a new set next week. Oddly, the upgrade/mod worked fine on their demo set. Anyway, FYI...

best,


k
 
Last edited:
B

bonesetter

Guest
Hi, I had similar problem with a brand new out of the box Vantages... had to send them back. The panel housing had been cracked, probably during transit, and I guess the membrane may have been damaged too
 

JonFo

Super Moderator
Moderator
Joined
Jan 16, 2005
Messages
4,148
Reaction score
50
Location
Big Canoe, GA
Man, what’s going on? Either transport is rougher than before or the build issues are getting more prevalent.

In a dozen years of owning ML’s and doing a good bit of work on them, I’ve never run across any of this.

The mounting of the panels is something one needs to be careful with, but this thread sounds like the problem is the electronics. Wonder if the offshore supplier QC is falling off?
 

Latest posts

Top