BALANCED FORCE 210!!!! HELP PLEASE

MartinLogan Audio Owners Forum

Help Support MartinLogan Audio Owners Forum:

NichoManifest

New member
Joined
Nov 30, 2021
Messages
1
Reaction score
0
Due to unfortunate circumstances i have recently inherited a Martin Logan home entertainment center. In the package i have a balanced force 210 subwoofer speaker. i have to part with it in order to pay funeral expenses and i am absolutely at my wits end. When testing out to begin with i had NO CABLES plugged into it except for the power chord into an outlet. To test it at home before trying to sale it (please keep in mind im not very tech saavy) i literally unplugged one of those red white and yellow RCA chords from an old dvd player i wasnt using and hooked one end up to my television and the other end into the subwoofer. While using my roku for youtube at home , it worked PERFECTLY. (great sound) Now heres the tricky part , once i unhooked it to take it to a friend of mines house to see if they would take it , upon testing it on his tv , it would not transmit sound. Normally i would think i messed something up but whilst the RCA chord is plugged to the back of the speaker , if you touch the connectors on the other end (the end that was plugged in audio ports of tv) it makes a booming noise which lets me know the speaker is still operable. But now that im back home with the original tv , it wont work again. I dont know what i did / or am doing differently from before but any assistance would really be greatly appreciated. I hope ive explained the situation well but if not please ask questions so that i may get this resolved as quickly as possible. Thank You in advance !
 
Joined
May 26, 2022
Messages
1
Reaction score
0
Where are you located? I suggest finding a Martin Logan dealer near you for assistance, they might be able to help you sell it as some will do so on consignment.
 

Northy

Well-known member
Joined
May 15, 2012
Messages
290
Reaction score
59
Location
Canada
I am very sorry about the sad circumstances. I wish you would have had a more pleasant experience getting an ML product. I have a 210 and it is a marvelous subwoofer. Do you have it on auto standby or always on? The red light should turn green when it gets a signal. Try to find a friend who has a receiver (any will do) and connect to it. Good luck and let us know.
 

Northy

Well-known member
Joined
May 15, 2012
Messages
290
Reaction score
59
Location
Canada
Mine is on auto standby too. And it is fairly quick. It will turn on as soon as it receives any signal below 120 HZ.
 

Northy

Well-known member
Joined
May 15, 2012
Messages
290
Reaction score
59
Location
Canada
Hi @Robert D , by the way, we had a road trip to Nashville going through Ohio back in May. You live in a lovely state. It has everything although most of the heavy industries have been eliminated. We stayed in Toledo and Cleveland.
 
Last edited:
Top