Quantcast

problem with the Theater center ?

MartinLogan Owners (MLO)

Help Support MartinLogan Owners (MLO):

Image

Member
Joined
Feb 14, 2005
Messages
14
Reaction score
0
Hello from germany ( sorry about my bad english i hope everbody understand me )

I buy the theater center a few weeks ago. Now i have this problem:

i hear no big different when the center are not on power. It was a
coincidence: I listen 5.1 music and want to open a window behind the center speaker and unintentionally the powercord from the center was pull out the wall after that. Now i mean the music sounds the same; with ore without power.
But this cant because the CLS panel dosent work without power? I go with my ear close to the panel and (without power) i can hear the music from it ...

how can this happend ? how big is the sound different with and without the power ? ... i think i take of the soft dome and woofer to test the CLS ?

Thanks Andre
 

Peter Hogan

Well-known member
Joined
Dec 31, 2004
Messages
294
Reaction score
0
Location
Fitchburg, MA
Image said:
Hello from germany ( sorry about my bad english i hope everbody understand me )

I buy the theater center a few weeks ago. Now i have this problem:

i hear no big different when the center are not on power. It was a
coincidence: I listen 5.1 music and want to open a window behind the center speaker and unintentionally the powercord from the center was pull out the wall after that. Now i mean the music sounds the same; with ore without power.
But this cant because the CLS panel dosent work without power? I go with my ear close to the panel and (without power) i can hear the music from it ...

how can this happend ? how big is the sound different with and without the power ? ... i think i take of the soft dome and woofer to test the CLS ?

Thanks Andre
Hi,
How long are you leaving them unplugged? I can unplug my CLS's and they will play fine for nearly a half hour before I notice them starting to lose sound from the static charge on the panel bleeding away. If you're unplugging the theater and expecting it to change immediately, that is probably your problem.

A better way would be to leave it unplugged overnight, then try it the next day, WITHOUT plugging it in. Make note of the sound, and then plug it in. The sound should improve markedly (now instead of just the woofers working, the panel will be working too).

HTH,
Peter
 

Anthony A.

Well-known member
Joined
Jan 2, 2005
Messages
125
Reaction score
0
the theater center channel speaker only needs the power cord to charge the panels. once it is charged, you can disconnect the power to them and they will still work. the sound should be the same also, with or without the power cord. perhaps since cls's are older, the panels do not charge that fast, compared to the newer ML speakers.
 

Robin

Well-known member
Joined
May 9, 2005
Messages
3,292
Reaction score
0
Location
Calistoga, California
Theater speaker...

Andre,

The Theater center speaker without power, the soft cone tweeters(3) and the 6 1/2" woofers(2), as they do not require power (from that power connection), will continue to perform. But eventually, probably within an hour, the electrostatic pannel will not function, as the pannel requires power to operate.

Hope this helps... ;)

Cheers

-Robin
 
D

dyazdani

Guest
Dolfin said:
Why are you unplugging your speakers? :confused:
Dolfin, we don't all work for power companies! :) jk

I think he said he snagged a PC by mistake and noticed that it didn't affect the sound much...
 
Top