Clarity Issue

MartinLogan Audio Owners Forum

Help Support MartinLogan Audio Owners Forum:

A

audiophileman1234

Guest
I have a question for everyone. We own the Martin Logan Monoliths III's with the active crossover. When we have used them recently we have noticed that the bass is very pronouced even when at the lowest setting. The high end is not sharp at all for what we would expect and have heard from these speakers. Here is my system info below. If anyone has a solution or possible solutions let me know. Thanks a lot.

Speakers: Martin Logan Monoliths
Crossover: Martin Logan (active)
Preamp: Mark Levinson No. 26
Amp for high end: Mark Levinson No 23
Amp for Martin Logan Bass: Bryston 4b
Subs: Sumo Delilah (2 15" drivers)
Amps for subs: 2 Parasound HCA 1201a
Power Conditioner: Monster Power HTS ___
P.s. I hope its not the speakers or I may just have to order a pair of the Wilson Audio Watt/Puppy 8 System :cool:
 

roberto

Well-known member
Joined
Jan 1, 2005
Messages
3,312
Reaction score
82
Location
San Jose, Costa Rica
audiophileman1234 said:
I have a question for everyone. We own the Martin Logan Monoliths III's with the active crossover. When we have used them recently we have noticed that the bass is very pronouced even when at the lowest setting. The high end is not sharp at all for what we would expect and have heard from these speakers. Here is my system info below. If anyone has a solution or possible solutions let me know. Thanks a lot.

Speakers: Martin Logan Monoliths
Crossover: Martin Logan (active)
Preamp: Mark Levinson No. 26
Amp for high end: Mark Levinson No 23
Amp for Martin Logan Bass: Bryston 4b
Subs: Sumo Delilah (2 15" drivers)
Amps for subs: 2 Parasound HCA 1201a
Power Conditioner: Monster Power HTS ___
P.s. I hope its not the speakers or I may just have to order a pair of the Wilson Audio Watt/Puppy 8 System :cool:
Hola...usually, this problem is due to a low charge of the stat panels...
The sensitivity of the amplifiers could be another reason, but it looks that you had them working right...you could increase the volume to the stat power amplifier only or you need to replace the stat panels...it is the only possiblility...you are not saying that they don´t sound, but too much bass energy is present. right?... hope this can help...
Roberto.
 
Top