Fresco & screeching sound.

MartinLogan Owners (MLO)

Help Support MartinLogan Owners (MLO):

vinodk

Active member
Joined
Oct 19, 2005
Messages
34
Reaction score
0
Hi Guys!
I currently have ML setup with Aeon i(bi-amped), Theater i & Fresco's being driven by Sunfire amp. I get these weird intermittent screeching sound from rear channels only during different CSI editions during the musical score & has not happened with dvd's or any other programs on CBS or other channels. I am wondering if it is due to the source or something is wrong with Fresco's. First I thought that Sunfire is not able to handle all 5 speakers therefore I connected Fresco's to Pioneer 59TXi with Sunfire running the front 3 channels but it made no difference. Thanks in advance for any suggestions.
Vinod.
 

garmtz

Well-known member
Joined
Jan 3, 2005
Messages
250
Reaction score
0
If you don't hear it with any other DVD, it must be in the source... If you watch it 'on air', a lot of processing takes place, mocking up the sound. Probably, it's your surround processor being tripped by phase errors in the sound.
 

aliveatfive

Well-known member
Joined
Jan 1, 2005
Messages
776
Reaction score
0
I'm using Frescos for surround channels and Summits up front. Also watch CSI using this system. Prepro is a Rotel 1068 and power amp is a Bryston (for surrounds.) I do not have any of the problems that you mentioned in your set-up. I might be inclined to think the problem is electronics-related, unless your speakers are defective.
 

vinodk

Active member
Joined
Oct 19, 2005
Messages
34
Reaction score
0
I believe it is the source because I was watching football on my downstairs tv yesterday on CBS & I could hear the same screeching sound coming from the tv speakers as there is no surround setup. It must be a local Directv or CBS HD channel issue. Hopefully somebody from LA area can chime in.
 

Latest posts

Top