Quantcast

ESL stopped working

MartinLogan Owners (MLO)

Help Support MartinLogan Owners (MLO):

Alokmagan

New member
Joined
Aug 11, 2020
Messages
3
Reaction score
1
Both of my ESL were working fine till 2 days ago but yesterday i found that both of them are not amplifying and sounding very bad. I removed the power chord and reinserted but there is no impact whether power chord is there or not there. The blue light shows when i insert the power chord but nothing happens to the sound. There was a thunder storm on Sunday night, is it possible that some power surge damaged it. What options do i have to fix it ?
 

Robert D

Well-known member
Joined
Jul 21, 2020
Messages
199
Reaction score
22
I wonder if there is a fuse anywhere in the speaker? Are the speakers protected by any surge protection? Our power company offers a whole house protector i use, it fits on the meter outside and protects the home, has $10,000 insurance on it too. I also use a Furman power conditioner now.
 

roberto

Well-known member
Joined
Jan 1, 2005
Messages
3,166
Reaction score
33
Location
San Jose, Costa Rica
Both of my ESL were working fine till 2 days ago but yesterday i found that both of them are not amplifying and sounding very bad. I removed the power chord and reinserted but there is no impact whether power chord is there or not there. The blue light shows when i insert the power chord but nothing happens to the sound. There was a thunder storm on Sunday night, is it possible that some power surge damaged it. What options do i have to fix it ?
Hola. You might have a bad PSB modules (Power supply boards). These are an internal power supplies boards that polarize the stat panels with DC voltage. You have to take them to the shop where you bought them for service.

When you have storms, it is wise to disconnect all the power cords and the system from the Mains AC wall 120 ACV.
 

Robert D

Well-known member
Joined
Jul 21, 2020
Messages
199
Reaction score
22
If it was indeed a power surge that toasted something in your home, you can report it to your homeowners insurance and file a claim. You would be responsible for your deductible. Most policies have about $1000.
 

spkrdctr

Well-known member
Joined
Dec 23, 2017
Messages
64
Reaction score
16
Location
Clearwater Florida USA
First do some simple troubleshooting. Make sure it is your speakers and not your amp/receiver or even a preamp. Take any other speaker, hopefully cheap and small/easy to handle and hook it up to make sure it is the speakers. I am saying this as both speakers went out together which does happen, but let's make sure they really are fried. So, if another speaker doesn't work then it is not the speaker. Check both of them. If the small speaker works then it is the speakers. If they don't work you have to move to the amp as it is not putting out any power to the speakers. If it is not, then you need to go to the preamp. Sooner or later you will know exactly what is fried. Good Luck and if you have any questions be sure to ask. There is a lot of knowledge lurking on the forums. Everyone here will help out as much as they can.
 

Alokmagan

New member
Joined
Aug 11, 2020
Messages
3
Reaction score
1
Thanks all. Tried all the options. ML is sending me new power supply , hope that solves else will go with insurance option.
 

Robert D

Well-known member
Joined
Jul 21, 2020
Messages
199
Reaction score
22
Thanks all. Tried all the options. ML is sending me new power supply , hope that solves else will go with insurance option.
Wow, you got through to them fast. Were you able to speak to them on the phone, or was it emails? Just a few weeks ago I called and they weren't there to answer calls, all communication was via emails. Took about 2 weeks to get an email response. Sounds like their staffing might have just gone up.
 

RMoss

Member
Joined
Apr 19, 2012
Messages
5
Reaction score
0
Location
Huntsville, AL
Thanks all. Tried all the options. ML is sending me new power supply , hope that solves else will go with insurance option.
Did you have to purchase the replacement part and if so, what was the cost? I have one that is playing via woofer only (and no power LED).

I'm planning to swap power supply boards from one to the other to verify if that is the problem, but I'm fairly certain it is. Both external 15v units work.

Thanks!
 

Alokmagan

New member
Joined
Aug 11, 2020
Messages
3
Reaction score
1
ML service tech was generous enough to send the power supply free of charge. However, my insurance company advised me to take it to professional and have it repaired or replaced. I have given those for repair. Yet to hear the diagnosis and estimate :-(
 
Top