Quantcast

Cadence "Master Surround" not detected.

MartinLogan Owners (MLO)

Help Support MartinLogan Owners (MLO):

Ton459

Member
Joined
Oct 23, 2010
Messages
9
Reaction score
2
Location
Vancouver, BC, Canada
I sent this question to ML Service this week and am waiting for a reply, but perhaps other members have the answer.
I purchased my new Cadence a month ago and got it to work on my network and with Play-Fi without problems. However, I just received my 2 newly bought Bravado’s and tried to configure them in the Play-Fi app (IOS) as Surround speakers without success. I keep getting the message “No Speaker Detected - a master surround speaker is needed to setup rear surrounds.” I have looked everywhere how to setup the Cadence as Master but cant find it anywhere. Do I need a firmware update (MCU on 7.4 already) or something like that? Or should I return it to ML or the Dealer for exchange?
 

Ton459

Member
Joined
Oct 23, 2010
Messages
9
Reaction score
2
Location
Vancouver, BC, Canada
I sent this question to ML Service this week and am waiting for a reply, but perhaps other members have the answer.
I purchased my new Cadence a month ago and got it to work on my network and with Play-Fi without problems. However, I just received my 2 newly bought Bravado’s and tried to configure them in the Play-Fi app (IOS) as Surround speakers without success. I keep getting the message “No Speaker Detected - a master surround speaker is needed to setup rear surrounds.” I have looked everywhere how to setup the Cadence as Master but cant find it anywhere. Do I need a firmware update (MCU on 7.4 already) or something like that? Or should I return it to ML or the Dealer for exchange?
As an update, after corresponding with the DTS Play-Fi folks, it turned out my Cadence was not registered to be a Surround Master, and apparently could not be fixed with a firmware upgrade. After hearing that, ML agreed to replace the Cadence with a new one, so I sent mine to ML and received a replacement within 2 weeks. Hooked it up and connected my Bravado's via the Play-Fi app without a problem. Dolby Digital Surround is working really well (Atmos is not supported - haven't tried DTS yet)- just need to make sure all the smart speakers are connected to the 5GHz band on your Wifi - The wireless subwoofer connection works very well too. Well done ML for replacing the Cadence as per warranty! I can definitely recommend this set-up for loyal ML customers as a (wireless) secondary or casual movie surround system!
 
Top