2021 new gen Apple tv 4k Dolby Atmos Problems

MartinLogan Audio Owners Forum

Help Support MartinLogan Audio Owners Forum:

brockrohl

Member
Joined
Jul 14, 2022
Messages
12
Reaction score
12
Location
United States
If someone installs beta, can you revert back to the standard version if you want? I'm going to guess no.
I don't believe you can revert to standard releases with the 4k model since it no longer has a USB port to restore the factory image. You can opt to no longer accept beta releases inside the apple tv UI though if you only want to recieve mainline releases after accepting a beta image. So you could take the current beta image, and if it works for you, opt to not get any new release until the official build comes out. As someone previously mentioned, the public betas for Apple TV are generally very stable. I have never run into a problem personally and I have had the beta releases for nearly a year. I think the expected release date for the main release is September.
 
Last edited:

Robert D

Well-known member
MLO Supporter
Joined
Jul 21, 2020
Messages
2,023
Reaction score
463
Location
Ohio
I'm probably just going to wait until September to try the newest version, unless I start having massive troubles.

I'm excited to hear this news! If they have fixed the issue, it been about a year and a half since it all started. Better late than never. I'm glad because I really like most things about the device.
 

IraG

Well-known member
Joined
Dec 23, 2021
Messages
83
Reaction score
84
Location
Colorado
I spoke too soon. This weekend I had several issues during Stranger Things S04E08 and S04E09. I had the repetitive ticking sounds, and twice the audio dropped-out completely, requiring stopping and restarting the stream. And I was so confident that the problem was fixed after I made it completely through an episode of DtS without issue.

I guess I will be using my Roku for DV/Atmos programming. The ATV4K has been a disappointing waste of time and money. If the final release of tvOS 16 doesn't fix this issue, we should pressure Apple to refund our purchases. They really should make this right.
 

brockrohl

Member
Joined
Jul 14, 2022
Messages
12
Reaction score
12
Location
United States
I spoke too soon. This weekend I had several issues during Stranger Things S04E08 and S04E09. I had the repetitive ticking sounds, and twice the audio dropped-out completely, requiring stopping and restarting the stream. And I was so confident that the problem was fixed after I made it completely through an episode of DtS without issue.

I guess I will be using my Roku for DV/Atmos programming. The ATV4K has been a disappointing waste of time and money. If the final release of tvOS 16 doesn't fix this issue, we should pressure Apple to refund our purchases. They really should make this right.
That is a bummer! It hasn’t happened yet on my end after about 6 hours of Netflix, but I figure it’s only a matter of time before it comes back. Thanks for the update!
 

Robert D

Well-known member
MLO Supporter
Joined
Jul 21, 2020
Messages
2,023
Reaction score
463
Location
Ohio
I spoke too soon. This weekend I had several issues during Stranger Things S04E08 and S04E09. I had the repetitive ticking sounds, and twice the audio dropped-out completely, requiring stopping and restarting the stream. And I was so confident that the problem was fixed after I made it completely through an episode of DtS without issue.

I guess I will be using my Roku for DV/Atmos programming. The ATV4K has been a disappointing waste of time and money. If the final release of tvOS 16 doesn't fix this issue, we should pressure Apple to refund our purchases. They really should make this right.
Man, I had my hopes up a bit. I'm not surprised though. I truly believe that they will never fix the issue, at least not in this gen.

So the Roku plays the content fine? Why not just use it exclusively and throw the Apple in the back of the closet?

I'm thinking the Nvidia Shield might be my best bet, but now Roku is intriguing me. I'd like to have one device I use and not two.
 

Robert D

Well-known member
MLO Supporter
Joined
Jul 21, 2020
Messages
2,023
Reaction score
463
Location
Ohio
Last night my Apple tv remote bugged out. The volume controls stopped working on my Marantz. I tried deleting and then adding the programming back but no luck.

What worked was disconnecting the remote from Bluetooth, and then having it relink. You have to hold the home button down along with the volume down button for 5 seconds. Then hit any button to reconnect.
 

brockrohl

Member
Joined
Jul 14, 2022
Messages
12
Reaction score
12
Location
United States
I am about 12 hours of Netflix Atmos content without issue. At the very least it seems improved, if not fixed, on my end.
 

Robert D

Well-known member
MLO Supporter
Joined
Jul 21, 2020
Messages
2,023
Reaction score
463
Location
Ohio
Yeah
I am about 12 hours of Netflix Atmos content without issue. At the very least it seems improved, if not fixed, on m
Yeah, I was thinking that myself. Maybe at least the problem is less frequent. If it is, it is a trend in the right direction.

Hopefully IraG will come back on and report how things have been .
 

Robert D

Well-known member
MLO Supporter
Joined
Jul 21, 2020
Messages
2,023
Reaction score
463
Location
Ohio
My Apple tv is now offering a new update tonight. I'm running 15.5.1 now. Could this be the new tvos 16 that was in beta? I've not installed anything yet.

Watched Virgin River's latest season last night and the sound screwed up real bad. Rebooted and I made it through the remaining 40 minutes with no issues.
 

Robert D

Well-known member
MLO Supporter
Joined
Jul 21, 2020
Messages
2,023
Reaction score
463
Location
Ohio
Looks like the update is 15.6.

 

JonFo

Super Moderator
Staff member
Moderator
Joined
Jan 16, 2005
Messages
4,651
Reaction score
382
Location
Big Canoe, GA
I've upgraded to the TVOS 16 Beta, and so far, all has been working perfectly.

The Netflix series Virgin River - Season 4 is Dolby DV / DA, and when we played Episode 1 while on 15.5.1, we started experiencing the audio drops. After a cold boot, had one short occurrence, re-wound, and then never had one for the rest of that and the next episode.

We've now had the Beta for three days, watched four more episodes and other DV/DA content, like AppleTV+ For All Mankind, and the audio has been perfect so far.
 

barjohn

Well-known member
MLO Supporter
Joined
Apr 10, 2021
Messages
63
Reaction score
30
Location
Sarasota Florida
Something I just discovered today that I thought I would pass on. When I had my Atmos configuration (All Wireless via WISA) the only difference I noted in volume between a 2 channel recording and an Atmos recording was an increase in volume. Recently, I decided to do just a 2 channel stereo configuration and had the opposite happen. Two channel sound was way lower in volume when the selected tune was an Atmos or 2 channel coming from the ATV4K and Apple Music as the source but two channel coming from the ATV4K and YouTube music was significantly louder (I'm talking 30db+). Then I discovered, if I changed the audio setting on the ATV4K to stereo, I got the higher volume from Apple Music that was missing before. Very strange.
 

Robert D

Well-known member
MLO Supporter
Joined
Jul 21, 2020
Messages
2,023
Reaction score
463
Location
Ohio
I've upgraded to the TVOS 16 Beta, and so far, all has been working perfectly.

The Netflix series Virgin River - Season 4 is Dolby DV / DA, and when we played Episode 1 while on 15.5.1, we started experiencing the audio drops. After a cold boot, had one short occurrence, re-wound, and then never had one for the rest of that and the next episode.

We've now had the Beta for three days, watched four more episodes and other DV/DA content, like AppleTV+ For All Mankind, and the audio has been perfect so far.
Thats good news. I upgraded last night to the new 15.6 and Virgin River dropped out in the first 2 minutes of play. So 15.6 is no good too.
 

Robert D

Well-known member
MLO Supporter
Joined
Jul 21, 2020
Messages
2,023
Reaction score
463
Location
Ohio
Something I just discovered today that I thought I would pass on. When I had my Atmos configuration (All Wireless via WISA) the only difference I noted in volume between a 2 channel recording and an Atmos recording was an increase in volume. Recently, I decided to do just a 2 channel stereo configuration and had the opposite happen. Two channel sound was way lower in volume when the selected tune was an Atmos or 2 channel coming from the ATV4K and Apple Music as the source but two channel coming from the ATV4K and YouTube music was significantly louder (I'm talking 30db+). Then I discovered, if I changed the audio setting on the ATV4K to stereo, I got the higher volume from Apple Music that was missing before. Very strange.
Yeah, ive noticed that on apps that seem to stream everything only in stereo that the volume is extremely loud.
 

JonFo

Super Moderator
Staff member
Moderator
Joined
Jan 16, 2005
Messages
4,651
Reaction score
382
Location
Big Canoe, GA
hen I discovered, if I changed the audio setting on the ATV4K to stereo, I got the higher volume from Apple Music that was missing before
Question: are you still using an AVR?

If not, what device is the ATV connected to?

Your description makes it sound like what happens if someone uses an HDMI audio extractor for a 2ch analog line and the extractor is telling the ATV it supports 8ch LPCM.
 
Last edited:

Robert D

Well-known member
MLO Supporter
Joined
Jul 21, 2020
Messages
2,023
Reaction score
463
Location
Ohio
Using 15.6 now I'm finding zero problems watching For All Mankind on Apple tv+, but Virgin River on Netflix is about the worst I've ever had.
 

Robert D

Well-known member
MLO Supporter
Joined
Jul 21, 2020
Messages
2,023
Reaction score
463
Location
Ohio
It's strange how rebooting the unit allows me to watch 40 minutes or so without any interruptions. Last night Virgin River messed up in the first 2 minutes or so. I rebooted and was able to watch the rest of the show with no problems, 50 minutes or so. Then the next episode had sound dropout in the first 5 minutes. Reboot and repeat.
In the past, Apple tv+ shows would screw up, shows like See, but now it seems to be ok.
One of us on here has had the new OS 16 mess up Atmos sound, so it seems like the problem may still be there. It certainly seems to be much better though.
 
Top