Results 1 to 4 of 4

Thread: Summit crackling

  1. #1
    Senior Member
    Join Date
    Sep 2007
    Location
    doylestown, oh
    Posts
    423

    Default Summit crackling

    One of my summits makes a crackling noise when the blue power light shuts off! I donít notice any distortion while itís playing! Any ideas on what might be causing this? I have swapped panels and it follows the panel! Thanks

  2. #2
    Senior Member
    Join Date
    Sep 2007
    Location
    doylestown, oh
    Posts
    423

    Default

    Well it looks like i stumped the experts not even Reberto has an answer! There has to be a reason for this! Is it something to worry about? It seems itís a stat panel for sure! Also Iíve noticed even when it powers on it crackles. Then goes away

  3. #3
    Member
    Join Date
    Mar 2008
    Location
    Tucson, Arizona
    Posts
    112

    Default

    I used my purity pair for about 9 years (til September 2016) and I had the same issue with my left speaker. Any time it powered on but there was no other issues with it. I don't know why it kept doing that, but since there was no noise or hums during playback, I never cared about it.

  4. #4
    Super User JonFo's Avatar
    Join Date
    Jan 2005
    Location
    Big Canoe, GA
    Posts
    3,573

    Default

    My only thought on this is that there is some dust or other 'foreign' particles on the diaphragm that arc the stator when you power them on/off. I'd start by very thoroughly vacuuming the panel, then if that does not do it, then unmount the panel, and follow the shower cleaning method.
    If you unmount it, carefully inspect the edges of the panel for any warping or separation of the two stators, you could have some arcing due to an incomplete seal
    Jonathan

    System #45 (Monolith IIIx, Sequell IIb, SL3XC)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •